Charged IT Solutions LLC - Elevated Latency - Phoenix, US - DDoS Protection – Incident details

Elevated Latency - Phoenix, US - DDoS Protection

Resolved
Operational
Started 4 days agoLasted 1 day

Affected

Phoenix, AZ

Operational from 6:00 AM to 11:54 PM

DDoS Protection

Operational from 6:00 AM to 11:54 PM

Updates
  • Resolved
    Resolved

    We have applied mitigations on our end to bring latency metrics back down to reasonable levels. This incident has been closed out.

  • Identified
    Identified

    We are aware of elevated latency for traffic transiting our upstream provider for our DDoS protection services in Phoenix. We have engaged our upstream and will post updates when available.