Charged IT Solutions LLC - Connectivity Loss - London, UK - DDoS Protection – Incident details

Connectivity Loss - London, UK - DDoS Protection

Resolved
Major outage
Started 11 days agoLasted about 1 hour

Affected

London, UK

Major outage from 1:13 PM to 2:00 PM

DDoS Protection

Major outage from 1:13 PM to 2:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating this incident.