Charged IT Solutions LLC - DDoS Protection - AZS-1 - Phoenix, AZ – Incident details

DDoS Protection - AZS-1 - Phoenix, AZ

Resolved
Operational
Started 9 days agoLasted less than a minute

Affected

Iron Mountain - AZS-1 - Phoenix, AZ

Operational from 11:59 PM to 11:59 PM

Updates
  • Postmortem
    Postmortem

    On August 14th, our upstream provider experienced a software bug that required them to withdraw remote advertisements from their Phoenix datacenter location. Traffic was automatically diverted to their Los Angeles (LAX) location. Service returned to normal routing patterns today (August 19th, 2025) once the encountered software bug was corrected and route advertisements restored at the Phoenix location.

  • Resolved
    Resolved

    DDoS protection customers may have seen slightly elevated latency from Friday as connectivity was rerouted to LAX by our upstream provider. This has been resolved and all services are normal at this time.